
 

Tutorial: Crystal structure refinement of oxalic acid dihydrate using 
Jana2006 

The aim of this tutorial is to use Jana2006 to locate hydrogen in oxalic acid dihydrate 
and refine the crystal structure. By no means is it intended to provide a general recipe 
for structure refinement nor is it claimed the suggested route here is the best possible 
and only one to take. It serves as a mere example how it can be done. Oxalic acid 
dihydrate crystallises in the monoclinic space group P21/n with lattice parameters a = 
6.1143 Å, b = 3.5870 Å, c = 12.0109 Å and β = 106.127 °. The chemical composition 
is (COOH)2·2H2O.  
 

 
Installing the software 

Download Jana2006 from http://www-xray.fzu.cz/jana/jana.html and install it (don't 
forget to set the environment variables as described on the website - you need 
administrator rights on your computer in order to do this). 
 
Download the structure visualisation program VESTA from 
http://www.geocities.jp/kmo_mma/crystal/en/vesta.html and install it. 
 
Launch Jana2006 by double-clicking on the icon. 
 
In the Jana2006 menubar, select Tools→Programs.  
• In the dialog box that appears, set both Graphic viewer and 3d visualisation of 

maps to the full path name of VESTA (e.g. C:\Program 
Files\VESTA\VESTA.exe). Click OK to exit. 

 

 
Preparing the data 

The first thing we need to do is to prepare the SXD data. The crystal has been 
measured at five different omega settings (orientations) for about 1 hour at each 
setting. The temperature was close to 300 K. The raw data have been indexed and 
integrated using SXD2001. However, we still need to calculate the absorption 
correction and convert the files to GSAS histograms. To perform the absorption 
correction, start SXD2001, load the “SXDII.instr” file and click Calc. corrections 
(Fig. 1). 
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Figure 1: SXD2001 main GUI. The location of the Calc. corrections button is 
indicated. 
 
A GUI similar to the one shown in Figure 2 should appear. The quantities to be 
specified by the user are the scattering and absorption cross section per atom and the 
number density in units of Å-3. Information about the cross sections can be found on 
the internet at http://www.ncnr.nist.gov/resources/n-lengths/. They are summarised in 
Table I. 
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Figure 2: Initial appearance of the calculate corrections GUI. 
 
Table I: Scattering and absorption cross sections of C, O and H (values taken from 
http://www.ncnr.nist.gov/resources/n-lengths/). 
Element Scattering cross section 

[barns] 
Absorption cross section at 
1.8 Å [barns] 

H 82.02 0.3326 
C 5.551 0.0035 
O 4.232 0.00019 
 
As can be seen from Table I, the scattering cross section, which is the sum of the 
coherent and incoherent cross sections is very large for hydrogen. This is mainly due 
to the large incoherent cross section of hydrogen. This large cross section of hydrogen 
is often causing a large slowly varying background in the diffraction pattern. A way 
around this would be to replace deuterium for hydrogen. The scattering cross section 
is nearly independent of the energy, while the absorption cross section varies linearly 
with wavelength. Thus, this value is usually quoted for neutrons having a wavelength 
of 1.8 Å corresponding to a neutron speed of 2200 m/s or a thermal energy of 293 K. 
 
As mentioned in the introduction, the chemical composition of oxalic acid dihydrate 
is (COOH)2·2H2O. The scattering and absorption cross section per atom are calculated 
as follows: 
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where n is the number of atoms in the formula and i

absσ , i
scatσ  are the absorption and 

scattering cross sections, respectively, for atom i in the chemical formula. 
 
Using the values in Table I compute the absorption and scattering cross section and 
enter them in the corresponding field in the Calc. corrections GUI. If you need a 
calculator, Window XP usually supplies one in the Start→All 
programs→Accessories menu. 
 
Next, we calculate the number density. This number is defined as the number of 
atoms divided by the unit cell volume. This should be straightforward…(Hint: there 
are Z = 2 formula units per unit cell). Insert the result in the corresponding text field 
in the Calc. corrections GUI. The number density can also be derived from the mass 
density. This is left as an exercise to the reader (Hint: Use Avogadro’s number). 
 
Select the intensity files “sxd17210_1sb.int’”, “sxd17211_1sb.int”, 
“sxd17212_1sb.int”, “sxd17213_1sb.int” and “sxd17214_1sb.int” using the Browse 
button in the Calc. corrections GUI (Fig. 3). These files contain the results of the 
peak integration for the runs sxd17210–sxd17214 corresponding to the runs for the 
present compound. For convenience, these files are located on the desktop. 

 
Figure 3: Select the reflection files for use in Jana2006. 
 
Finally, we need to know the sample shape. In our case, a cylindrical shape will be 
good enough. Specify a radius of 0.2 cm and a height of 0.4 cm. Select ‘Gaussian 
Integration’ with a precision of 32 points. The latter parameter corresponds to the 



number of grid points used in the numerical integration – the higher, the more precise 
but also the slower the calculation will be. 
 
Select Calculate absorption and Calculate extinction but leave the selection at Tbar 
only. This is the absorption weighted path length through the crystal and is needed for 
the Becker-Coppens type extinction correction (discussed later). The GUI should now 
appear similar to the one shown in Figure 4. Note, that the absorption and scattering 
cross section as well as the number density have been omitted and are left to the user 
to be calculated as an exercise. They are needed, so don’t omit them! 
 

 
Figure 4: Specify the scattering and absorption cross section as well as the number 
density. 
 
To calculate the corrections click Calculate and wait until the text window just above 
says that it is done. Then exit. 
 
The reflection files are now ready for importing into Jana2006. In the SXD2001 
menubar, select File→Generate Jana2006 reflection file.  
• A dialog box pops up asking for the reflection files. Point the directory path to 

your desktop and select simultaneously sxd17210_1sb.int – sxd17214_1sb.int as 
shown in Figure 5. Click Open.  

• In the dialog box that appears, leave all the options as they are (make sure to 
retain the default selection of One histogram per crystal) and click OK to finish 
the export. Set the exported filename to “Oxalic_acid.int”. 

 



 
Figure 5: Select the reflection files. 
 

 
Setting up the refinement 

Create a new folder in My Documents (or wherever you wish to work in the Windows 
directory structure) called (e.g.) “Oxalic acid”. Copy the SXD data file 
“Oxalic_acid.int” into this directory. This is the only file you need to start with – it 
contains all the integrated and absorption-corrected data, as well as the unit cell 
information. 
 
In the Jana2006 menubar, select File→Structure→New.  
• In the dialog box that appears, select the directory you just created and enter the 

filename “Oxalic_acid”. Click on Next to continue.  
• In the next dialog box, select Single crystal known diffractometer formats. Click 

on Next to continue. 
• In the next dialog box, select ISIS SXD and set File name to “Oxalic_acid.int”. 

Click on Next to continue. 
• In the next dialog box, make sure that it has read the lattice parameters correctly 

(see above). Click on Next to continue. 
• In the next dialog boxes, click on Next and OK to get through the next couple of 

dialog boxes (note that the program should have read 1320 reflections), the click 
on Finish to start pre-processing the data. 

• In the next dialog boxes, click on OK and Yes until you get to the symmetry 
dialog box, then set Space group to “P21/n” and click on Complete the set. In the 
dialog box that appears, select the option “P 1 21/n 1” (b-axis unique, which is the 
standard setting) and click on OK then Yes. Click on Next to continue. 



• In the next dialog box, click on OK, then select Use non-averaged data (you 
cannot average the data because you will need to perform a variable-wavelength 
absorption correction). Click on Next to continue. 

• In the next dialog box, click on Finish to complete data pre-treatment. 
• A dialog box now appears that concerns automated structure solution. You do not 

need to perform this task, so click on Esc to exit the last dialog box and return to 
the Jana2006 desktop. 

 
On the Jana2006 desktop, double-click on icon EditM50.  
• In the Composition tab of the dialog box that appears, set Formula to “C2 O6 

H6” and Formula units to “2”. Click on Calculate density to check that it is 
reasonable (should be 1.6083 g cm-3). Click on OK then Yes to return to the 
Jana2006 desktop. 

 

 
Inserting atoms 

The (relatively) heavy carbon and oxygen atoms have already been found using X-ray 
diffraction, and are listed in Table 2. 
 
Table 2: Positions of carbon and oxygen 
Atom x y z 
C(1) -0.045  0.054 0.052 
O(1)  0.084 -0.059 0.149 
O(2) -0.220 0.231 0.037 
O(3) -0.049 0.112 0.319 
 
In the Jana2006 menubar, select Parameters→Atoms→New. Click on OK to 
proceed by entering the atomic positions from the keyboard.  
 
• In the dialog box that appears, set Type new atoms coordinates to “-0.045 0.054 

0.052” and hit the “tab” key to move those numbers across to the list on the right. 
Click on Use typed in coordinates then Include selected peak to proceed. 

• In the next dialog box, set Name of atom to “C1” and Atomic type to “C”. Click on 
OK to return to the previous dialog box, where you can enter another atom.  

• Repeat the last two steps for all atoms in the Table 2, giving them suitable names 
and atom types.  

• When you have finished entering all the atoms and returned to the first dialog box, 
just click on OK without having entered any coordinates in order to exit. Click on 
Yes to enter the atoms and set up the initial structure. 

 

 
Check that the initial structure looks reasonable 

In the Jana2006 menubar, select Tools→Graphic→Run viewer to launch VESTA. 
 
In the VESTA menubar, select Edit→Bonds. In the dialog box that appears, set 
Search mode to “Search atoms bonded to A1”, set A1 to “C” and click Add. Click OK 
to draw the bonds.  
 



You should see sensible-looking C-C and C-O bonds. Assuming that all is well, exit 
VESTA (In the VESTA menubar, select File→Exit and click No.) 
 

 
Initial refinement 

We are now ready to start some initial refinements.  
 
On the Jana2006 desktop, Right-click on the icon Refine.  
• In the dialog box that appears, go to the Select/Listing tab. Untick Use 

unobserved reflections and set Unobserved reflections  to I<2*sig(I). Click on OK 
to proceed.  

• Click on Yes+start to start the refinement. 
 

Rw(all) should go down to ~43 %. 
 
It is a good idea to look at the structure again in VESTA again to check that nothing 
unreasonable happened, then return to Jana2006. 
 

 
Finding the hydrogens 

On the Jana2006 desktop, Right-click on the icon Fourier.  
• In the dialog box that appears, go to the Basic tab. Select Map type = “F(obs)-

F(calc) - difference Fourier”. Click OK and then Yes to launch the calculation, 
then Yes to open the listing (this option disappears after 10 seconds – if you 
weren't quick enough, go to the Jana2006 menubar and select Edit/view→View of 
Fourier.) 

 
Scroll to the bottom of the Fourier output listing, and you should see that there are 3 
strong negative peaks. These should correspond to your hydrogen atoms, since H is a 
negative neutron scatterer.  
 
Write down the fractional coordinates (x, y and z values) of those 3 peaks, and close 
the window. 
 
[NB: when Jana2006 is updated, it should be possible to visualise these peaks in 
VESTA by selecting the Include peaks from Fourier calculation option, but for the 
moment this does not work for negative peaks.] 
 
In the Jana2006 menubar, select Parameters→Atoms→New. 
• In the dialog box that appears, select Coordinates from keyboard and enter the 

fractional coordinates of the 3 hydrogens, labelling as H1, H2 and H3 with atoms 
type H (in the same way that you entered the C and O atoms above). [NB: when 
Jana2006 is updated, it should be possible to use the Coordinates from last 
Fourier option, removing the need to write them down and type them in again, but 
for the moment this does not work for negative peaks] 

 
Look at the structure again in VESTA to check that these H positions are reasonable. 
(NB: do not select the include peaks from Fourier calculation option, as this will only 
include the positive ones). 



 
You should see that one of the H atoms is bonded to an O of the oxalic acid molecule, 
completing the acid; while the other two are bonded to an isolated O to make a water 
molecule. 
 
Assuming that this is the case, exit VESTA to return the the Jana2006 desktop. 
 
You can now re-refine the structure with the H atoms included. 
 
On the Jana2006 desktop, double-click on icon Refine. 
 

Rw(all) should go down to ~26 %. 
 

 
Extinction correction 

A very important correction in neutron single-crystal diffraction is extinction. 
Compared to X-ray diffraction, crystals for neutron diffraction are quite large. Even in 
the absence of absorption effects, extinction often still is important. Note that there 
are different models available to describe extinction, and it is not necessarily clear 
which model should be used (one might have to try different models). In our case we 
will use a “Type I” Lorentzian distribution model. 
 
In the Jana2006 menubar, select Parameters→Extinction.  
• In the dialog box that appears, select Isotropic, Type 1 and Lorentzian. Set Radius 

to “0.3” cm.  
• Although extinction has been “turned on”, it is still set to zero so will have no 

effect unless it is refined. Make sure the box is ticked to refine the absorption 
parameter, then click on OK to return to the Jana2006 desktop. 

 
On the Jana2006 desktop, double-click on icon Refine. 
 

Rw(all) should go down to ~12 %. 
 

 
Finalising the refinement 

As a final step, we would like to change the atomic displacement parameters (often 
loosely referred to as “thermal parameters”) from isotropic spheres to anisotropic 
ellipsoids. 
  
In the Jana2006 menubar, select Parameters→Atoms→Edit/define atoms.  
• In the dialog box that appears, select “harmonic” ADP’s for Atom #1. (Note that 

“Anharmonic” ADP’s require more data that you have available in this case.) 
• Change the atom number to “2” and set it to “harmonic” ADP’s as well. 
• Continue until all 7 atoms are “harmonic”, then click OK, OK and Yes to return 

to the Jana2006 desktop. 
 
On the Jana2006 desktop, double-click on icon Refine. 
 

Rw(all) should go down to below 9 %. 
 



 
Extracting the results for publication 

You have now taken the refinement as far as it will go using the available data. It is 
time to extract the results into a standard crystallographic information file (CIF) for 
publication, and to procude some pretty pictures to go with it.  
 
In the Jana2006 menubar, select File→CIF Utilities→Make CIF file and click on 
OK to create the file “Oxalic_acid.cif” and return to the Jana2006 desktop. 
 
In the Jana2006 menubar, select Tools→Graphic→Run viewer to launch VESTA. 
 
In the VESTA menubar, select Edit→Bonds. In the dialog box that appears, set 
Search mode to “Search atoms bonded to A1”, set A1 to “C” and click Add, then set 
A1 to “O” and click Add. Click OK to draw the bonds and return to the VESTA 
desktop.  
 
You should see sensible-looking C–C, C–O and O–H bonds forming the oxalic acid 
and water molecules. Note that the H on oxalic acid is hydrogen-bonded to the O on 
the water molecule.  
 
On the VESTA desktop, click on Properties and go to the Atoms tab of the dialog box 
that appears. Select Show as thermal ellipsoids and tick Hide nonbonding atoms, then 
click OK to update the picture and return to the VESTA desktop. Note that the ADP’s 
look quite reasonable in terms of thermal motion perpendicular to covalent bonds. 
 
In the VESTA menubar, select Boundary. In the dialog box that appears, set x(min) 
to “-0.1”, x(max) to “1.1”, y(min) to “-0.1”, y(max) to “1.1”, z(min) to “-0.15” and 
z(max) to “1.15”. Click OK to draw the expanded cell and return to the VESTA 
desktop. 
 
You should now have a picture that looks something like Fig.6. You can save this file, 
print out the picture and/or export it to various formats as you like. 
 

 
Figure 6: The final structure of oxalic acid dehydrate. 
 


